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Application Notes:
Videophone & Audiophone configuration

Revision History

The table below contains the history of changes made to the present document.

Version Date Description

01 2016 First version
02 April 2017 Add the MorphoAccess® Sigma Extreme product
03 December 2017 Update the MMI of MorphoAccess® Sigma product

Update company name (IDEMIA)

04 July 2018 Add the support of H264 codec
05 July 2018 Add MorphoWave® Compact support
Introduction

The purpose of this document is to provide an overview of available possibilities to configure
videophone call on a MorphoAccess® terminal or Audiophone call on a MorphoWave® Compact

terminal.

Important: Videophone feature is only available for MorphoAccess® SIGMA Series and SIGMA
Extreme Series terminals. Audiophone feature is only available for MorphoWave® Compact terminals.

NOTE: This document is compatible with the audiophone feature of MorphoWave® Compact terminals.

Some preconditions are required before being able to configure and use videophone feature:

e Videophone software using SIP protocol installed on PC:
o Jitsi (2.8.5426 version or below) or,
o Linphone (3.8.1 version or below)

e Microphone on PC side

After preconditions are fully met, videophone configuration can be configured by two ways:
1. Directly on terminal panel
2. Remotely with MBTB software (MorphoBioToolBox) version 3.4.1 or higher

Configurations for software used on PC are also described:
1. Jitsi
2. Linphone

Next chapters describe in details the steps to follow in each case.
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Videophone configuration

In order to access Videophone, some parameters have to be set in terminal.
Parameters are:

e PC IP Address
e Port

Remark: Port used by default by Jitsi and Linphone is 5060

Videophone configuration via terminal menu

Below is the detail of the steps to follow in order to set parameters value via terminal interface.

1. Power up MorphoAccess® SIGMA Series and SIGMA Extreme Series terminal
2. Enterin Menu

16:01:33 09/26/2016

Figure 1 : Enter in configuration menu

3. Enter Password and validate to access configuration menu on terminal

Enter Password

Figure 2 : Enter password
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4. Enter in System Menu

Figure 3 : Enter in System Menu

5. Choose Terminal Settings

System Menu
| Terminal Settings
i Transaction log

x Miscellaneous Settings

P First Boot Assistant

Figure 4 : Choose Terminal Settings

6. Choose Videophone Configuration

Terminal Settings
Set Factory Default
Date/Time Settings

SDC/TOM/Tamper

v Vv Vv W

LCD Configuration

Figure 5 : Choose Videophone Configuration
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7. Choose Add

Videophone Configuration

View »

Delete >

Figure 6 : Enter parameter's value

8. Enter a server name, this name is arbitrary and help you if you have added several
videophone configurations

Enter Server Name

Figure 7 : Enter Server name

9. Enter Server IP address
Remark: Parameters in following steps are given as example
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Enter Server IP address

192.168.2.2

Figure 8 : Enter Server IP address

10. Enter Server Port

Enter Server Port

Figure 9 : Enter Server port
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Videophone configuration via MorphoBioToolBox (MBTB)

Below is the detail of the steps to follow in order to set parameters value via MBTB
(Administration Software).

Important:

MBTB has to be connected on the same network and subnetwork as the MorphoAccess®
SIGMA Series or SIGMA Extreme Series terminals. Please check your computer network
settings has an IP address on the same subnet as MorphoAccess® SIGMA Series and SIGMA
Extreme Series terminals in order to establish the connection without problem.

1. Power up MorphoAccess® SIGMA Series and SIGMA Extreme Series terminals

2. Start MBTB and enter IP address of MorphoAccess® SIGMA Series and SIGMA Extreme
Series terminals

Figure 10 : MBTB Enter IP address of terminal

3. Click on Connection. Connection should succeed.
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4. Enter in Settings Menu

Figure 11 : MBTB Enter in Video Settings Menu

5. Click on New

Figure 12 : MBTB Select New Videophone Configuration
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6. Enter the Profile Name, IP address and port server

Figure 13 : MBTB Enter Videophone configuration parameters

7. Click on Write button to save changes
Remark: Parameters are given as example

Figure 14 : MBTB Enter parameter's value
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Software configuration

Below is the detail of the steps to follow in order to configure the videophone software on
the Administrator PC.

Videophone call is compatible with the following software:

= Jitsi (version 2.8.5426 or below)
= Linphone (version 3.8.1 or below)

Note:

The configurations done in the following section are in the case that the Administrator PC
network settings has an IP address on the same subnet as MorphoAccess® SIGMA Series and
SIGMA Extreme Series terminals.

For other configuration, please contact your network administrator.
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Jitsi
Account configuration

1. Select Add new account... from File menu
2. Select SIP network and enter the ID and password
Remark: ID is arbitrary

F ™y
& Add new account ﬁ

Metwork SIP SIP -

User name and password
SIP id PC_server

Ex: john@voiphone.net or simply "john" for no server

Password essss

Remember password

(o) e

Figure 15 : Jitsi Enter account information

w

Click on Add button to save

4. By default, port 5060 is used by lJitsi, If you need to change it, navigate to Tools >
Options

5. Select the SIP account to edit then click on the Edit button

6. Under the Connection tab, you can edit the port used by the software

Account  Connection Security Presence Encodings

| S I P Registrar Port 5060

Authorization name »

Figure 16 : Jitsi Change port used by Jitsi (optionnal)

7. Click on Next then Sign in buttons to save the change
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Codecs configuration

1. Select Options from Tools menu
2. On Audio tab, only check the speex/16000 codec on the Encodings list

| & Option _— -

-

LEHQF@#

Accounts  General Video Security Events Chat Advanced

| Devices |- Encodings
[} opus/48000
[C]SILK/24000
ISILK/16000
[7]G722/16000

[ | speex/32000

. speex/16000

[ PCMU/8000
[C]PCMA/B000
[C]iLBC/8000

(] GSM/8000

[ speex/3000
[]G723/8000

D telephone-event/8000
("] AMR-WB/16000 m
[ SILK/12000 -

»
|-
=

m

Figure 17: Jitsi Select audio codec

3. OnVideo tab, check the H263-1998 codec and H264 in the Encodings list

| & Option — x
3 .
1 | =
A &= |9 F @ &
Accounts General Audio Videa Security Events Chat Advanced
Devices | Encodingsp More s:ttings\
H263-1998 Up
[C1H264 =
[red
[T ulpfec
[|vPs
[ |
Figure 18 : Jitsi Select video codec
Remark : the figure 18 is not up-to-date with the H244 codec support
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Linphone

Important:

Due to codec incompatibility, Linphone software can only be used with 3.8.1 version or
below.

Account configuration

1. Select Preferences from Options menu

2. Select the Manage SIP Accounts tab

3. Click on Add button under the Proxy accounts section

4. Enter Administration information under Your SIP identity
sip:<ID>@<id address of the pc>:<port to use>
Remark: ID is arbitrary

rﬁ Linphone - Configure a SIP account ﬁw
Configure a SIP account
Your SIP identity: kip:pc_server@192.168.2.2:5060
SIP Proxy address: sip:mph
Registration duration (sec): |3600 o
| Transport UDP v |
Route (optional):
Contact params (optional): I
AVPF regular RTCP interval (sec): 5 S
= Reqister

- Publish presence information
-l Enable AVPF

QEQK | %Qancel‘

Figure 19 : Linphone Configure SIP account

5. Click on OK to save the changes
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Codecs configuration

1. Select Preferences from Options menu
2. Select the Codecs tab
3. For audio codecs, enable only the speex (rate 16000 Hz) codec

(5§ settings | emee— - = =] EENE]

[EiNetwork settings | Multimedia settings #pManage SIP Accounts < Codecs| i) User interface
Codecs
Audio codecs :J

Name| Rate (Hz) Status_| IP Bitrate (kbit/s) Parameters ...~ _.yp

speex 16000 Enabled 40.000000 vbr=on
41 pown
W @ enable

-
1 s » . Disable

idth control

Download speed limit in Kbit/sec: 0 :g

Upload speed limit in Kbit/sec: 0 :?j

Adaptive rate control is 8 technique to
dynamically guess the available bandwidth during -l Enable adaptive rate control

a call.
J Done

Figure 20 : Linphone Select audio codec

4. For video codecs, enable H263-1998, H263 and H264 codecs

-
=] Settings  eme—— Biols
[ElNetwork settings | Multimedia settings f#pManage SIP Accounts < Codecs| i) User interface
Codecs
Video codecs :J

Name | Rate (Hz)l Status | IP Bitrate (kbit/s) Parameters ...~ _.yp

H263-1998 20000 Enabled 1500.000000 CIF=1;QCIF=1

H2632 90000 Enabled 1500.000000 J} DowD

Download speed limit in Kbit/sec:

Upload speed limit in Kbit/sec:

Adaptive rate control is a technique to
dynamically guess the available bandwidth during -l Enable adaptive rate control

a cail.
Q{? Done

Figure 21 : Linphone Select Video codecs

Remark : the figure 21 is not up-to-date with the H244 codec support

5. Click on Done button to save changes
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Videophone call

Once configuration on terminal and Administrator PC is done, a videophone call via the
terminal panel can be performed.

Important:

Administrator PC where videophone software is installed has to be connected on the same
network and subnetwork as the MorphoAccess® SIGMA Series and SIGMA Extreme Series
terminals. Please check your computer network settings has an IP address on the same subnet
as MorphoAccess® SIGMA Series and SIGMA Extreme Series terminals in order to establish
the connection without problem.

Administrator should verify that ports used by software and terminal are authorised (for
example port 5060 by default for Jitsi and Linphone).

Videophone software must be already launched on Administration PC.

1. Onthe terminal, click on the Videophone icon

11:16:50 0272072017

Figure 22 : Select Videophone menu

2. Select the server to contact on the list

Figure 23 : Select PC to call
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3. Click on the Call button

Server names

DC

Figure 24 : Make a call

4. On Administrator PC side, click on Answer to accept the call coming from terminal

| MORPHOACCESS is calling...

' | MORPHOACCESS@192.168.2.4 e | ™

To: PC_server (RegistrarLess SIP)

Figure 25 : Jitsi Accept a call

T irorere === =)

Options  Help

-5IP address or phone number:

Contacts ZRecent calls ()Call #1
(J MA j  —— Incoming call Duration ———

Sip:zMORPHOACCESS@192.168.2.4

+ A (.3) Answer @Decline
My current identity:
sip:pc_server@192.168.2.2:5060 &j (t:.)

sipMORPHOACCESS@192.168.2.4 is contacting you.

L

Figure 26 : Linphone Accept a call

5. On terminal, you should see the feedback of the terminal’s camera and hear from the
Administrator PC.
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Note:

You can adjust the volume with the slider on the right side of the LCD panel.

Push to talk

Figure 27 : MorphoAccess® SIGMA Series terminals Videophone interface

Figure 28bis : MorphoAccess® SIGMA Extreme Series terminals Videophone interface
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6. On Administrator PC side, you should see the feedback of the terminal camera and

micro.

& 00:01:10 | Call

®

n

X1 0¢ 3

i =

Figure 29 : Jitsi Videophone interface

ey, W

MORPHOACCESS (MORPHOACCESS@192.168.2.4)

[ )

B Linphone - Video call with sip:MORPHEES. | (Il | =5 inphons

Options  Help

SIP address or phone number:

Contacts

(5 ma )

+7/=

My current identity:
sip:pc_server@192.168.2.2:5060

Registratien on sipimph failed: io error

ZRecent calls () Call #1

@ Record

In call

00::01::03 SSRIEGRRGE 11

Sip:MORPHOACCESS@192.168.2.4

== \ideo ‘ Z‘ Fause | | Mute ‘
@Transfer @Hang up %Conference

aj ()

Figure 30 : Linphone Videophone interface

7. On terminal, hold the microphone button to
Once button is pressed :

speak

e Administrator side will be able to hear sound from MASigma series or

MAExtreme series terminals
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e Terminal speaker will remain silent as long as button is pressed
Administrator side won’t be audible

Push to talk

Figure 32bis : MorphoAccess® SIGMA Extreme Series terminals Hold button to speak

8. Release the microphone button to hear from the Administrator side
As long as button is not pressed :
e Administrator side won’t be able to hear sound from MASigma or
MAExtreme terminal
e Administrator side will be audible
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Release to hear

Figure 33 : MorphoAccess® SIGMA Series terminals Release to hear

Figure 34bis : MorphoAccess® SIGMA Extreme Series terminals Release to hear

9. Click on the Return button to end the call
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Push to talk

Figure 36bis : MorphoAccess® SIGMA Extreme Series terminals Stop Videophone
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